Roland XP-50 Music Workstation

roland_xp50

Right. The XP-50. I bought this one a few months ago. The problem with this one is that it only produces a loud static noise.. powers up just fine and the display also works fine. Time to open it up 🙂 Because XP-50’s are prone to failure there is a lot of information available online. The display seems to be the biggest issue but there are numerous problems that all boil down to this: leaking capacitors. The XP-50 is 20 years old and the mainboard contains 27 electrolytic SMD capacitors that unfortunately go bad over time. They cause all kinds of problems and the display is normally the first part that stops working. When that happens the display will light up (orange) just fine but it won’t display text anymore. This is caused by 3 capacitors that are broken in that case. Other problems are no sound or distorted sound etc. There seems to be a pretty high succes rate when you replace all 27 capacitors so I though I give that a try 🙂 I opened up the XP-50 and disconnected all the wires so that I could take out the mainboard:

20150506_194743 (Medium) 20150506_194748 (Medium)

The round silver thingies are the culprits:

20150506_200037 (Medium) 20150506_200042 (Medium)

Since they are SMD parts (surface mounted parts) it means that removing them requires a SMD soldering workstation. Which I don’t have. I’ve read online that twisting them off with a pair of small pliers works fine if you’re carefull so I though I’d give that a try:

20150506_201107 (Medium) 20150506_201137 (Medium) 20150506_201804 (Medium)

Surprise 🙂 they come right off! Very easy. After that carefully remove the black plastic parts that remain on the PCB and then comes the tedious part of desoldering the pins. I could now see that a lot of the capacitors have leaked. This is very difficult to see when the capacitors are still on the board. I removed all the remaining pins from the PCB and then used desoldering wire to remove the old solder. When desoldering a very corroded pin doesn’t work add some fresh solder and it will come off without a problem. After that clean the PCB with q-tips and alcohol to remove any leaked electrolyte.

20150506_213737 (Medium) 20150506_213729 (Medium)

I’m going to replace the caps with regular through-hole electrolytic capacitors because I can solder those on with a normal soldering iron. I’ll try to finish it next week.

Update june 2nd 2015: I’ve replaced all caps but the problem remains :’) I’ll check some things later..

xp50 (Medium)

Update june 8th 2015:

I’ve removed all the new caps and cleaned the PCB again. I also checked all the traces going to and from the pads leading to the caps and I found one open trace. I repaired this and soldered all the caps back on. I reinstalled the mainboard and switched the XP-50 on: still the same problem :’) Only loud crispering static noise.. I’m not going to be able to fix this. I’ll probably sell it for parts or as a ‘for parts’ XP-50…

I have an old worn dirty JV-80 waiting for some desperate TLC in the attic. Moving on 🙂

Advertisements

7 thoughts on “Roland XP-50 Music Workstation

  1. Contact me via email and we can take a look at the synth, I’ve been recently working on some Rolands and Im sure there must be a fix for your unit. Cheers!!

    Like

    1. Need help…
      I have a xp 50 with alike similar problem..
      When I connect audio output jack ( mono-L / Headphone), a loud sticky / buzzy sound come out of amp or speaker. I use to off & on power switch to get rid of the noise but It continues for 5 or 10.. Then it turn into normal for the time use it then.. 😦
      What to do, any solution here please???
      You can Email to> sharifnewag@gmail.com
      Thanks in Advance..

      Like

    1. Hi Robson,

      You can use these:

      14 x 10uF 16V
      05 x 47uF 6V
      03 x 100uF 6V
      02 x 330uF 6v
      02 x 0.1uF 50V
      01 x 4.7uF 50V

      I couldn’t get 6V caps so I used 16V instead of 6V.

      Good luck with the repair 🙂

      Like

  2. Hello there:
    Very interesting post. Do you know if the XP-50 uses the same main board as the XP-60 and 80?
    I do not recall, but when I recently examined my XP-60 Main Board, it also works on XP-80.

    Does the XP-50 and XP-60 use the same board?

    Like

    1. Hi Marc,

      I’m not sure but I don’t think so. If you look at this picture:

      XP-50 Mainboard

      You can see that the mainboard of my XP-50 says: “XP-50 MAINBOARD ASSY” so the XP-60 probably has a different one. I’ve seen other mainboards like the Roland D-10 where the mainboard says something like “Roland D-10 / D-20 Mainboard”.

      Jorick

      Like

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s