Yamaha SY85

yamaha_sy85

I recently bought a Roland JV-1000 and this Yamaha SY-85 came with it as a package deal. It needs a bit of work but the people a Vintagesynth.com seem to be pretty enthusiastic about this synth so it’s worth fixing up.

The previous owner said the diskdrive didn’t work which seems to be a pretty common problem for this synth. I plugged it in and played with it for a little while. I noticed that all the presets contain exactly the same boring patch. Probably an empty backup battery. There is also a problem with 1 black key. I think something broke off that key because it’s a bit loose. Also the plug where you plugin your powercord has been replaced in a rather hackish way and the on/off switch is broken / missing so when you plug the synth in it powers right up. Apart from that it still looks pretty good.

Time to take it apart 🙂

As soon as I turned it over I noticed half the screws are missing. This thing has been taken apart before. I’ve noticed the following problems:

  • Powerswitch broken
  • Ugly power connector solution
  • positive terminal from backup battery broken off
  • 1 black key broken

The drivebelt from the floppy drive looks intact though. It’s a bit loose and that might be a problem. The replacement belt can be bought easily though.

Here are some pics.

Ugly power connector and broken power switch:

Broken backup battery and broken black key. There is a good black key next to it. Notice the differences. Someone has tried to repair this black key.

And the floppy drive:

20151205_135447 (Medium)

Now I need to order some parts and fix it 🙂

Update december 25th 2015:

Yesterday some new parts arrived. I bought a replacement key, a battery and a powerswitch from Synth-parts.com.

Here are the new parts:

In the left picture the old and new power switch. In the right picture in the back the old broken key, in the middle a good key and in front the replacement key. It’s a used one but it looks absolutely brand new. It’s identical to the other keys exept a small extra pin halfway the key. Don’t know yet if thats going to be in the way and if it is I’ll trim it off.

I soldered in the new powerswitch and the new backup battery. Now I still need to fix the ugly powerconnector thing and replace the key. After that: put the whole thing back together and reload the factory data via MIDI and see if everything works. Not sure if I’m going to fix the floppydrive (if it’s broken at all..). Don’t know if you will ever use it because you can load everything via MIDI as well I think..

Last pic: old and new battery and where it goes on the mainboard. The new battery is a CR2032 (veeeery common) and the old one is a CR2450. The old one is larger but the new one fits perfectly and will work fine. They have the same 3v voltage. The CR2450 will probably last 20 years instead of the +-15 years for the CR2032 🙂

Update january 16th 2016:

Replaced the battery and broken key:

The bit of plastic in the red circle needed to be removed in order for the key to fit. In the bottom left picture you can see an original SY85 key, the replacement I got and the broken one.

After I replaced all the parts I put the whole thing back together and fired it up. Now all I needed to do was reload the factory settings.. after a little googling I found out that the program Electron C6 works better than Midi-Ox for the Yamaha. Also make sure you don’t have this cheap white / silver chinese USB Midi cable. Just throw that away. Trust me 🙂

I used a Roland UM-ONE midi cable, Electron C6 and a sysex file and it worked like a charm!

I got the Sysex files from here: SY85 Sysex

My SY85 has got ROM version 1.10. There seems to be a bug in that version that allows you only to import sysex data that was downloaded from another V1.10 SY85. That version is in the link above.

Check your ROM version by pressing [SHIFT]+[STORE]+[EXIT/NO]

The display will display something like this:

20160116_095120 (Medium)

 

Before you can send the sysex data you need to switch off the memory protection:

MODE -> UTILITY
SUB MODE -> SYNTH SETUP
Use PAGE arrows to select SYNTH MIDI 2 Page
Move F6 slider down to set Bulkprot to OFF
MODE -> VOICE

Now send the sysex file via Electron C6 and wait a minute. The display of the SY85 will say MIDI BULK RECEIVING until it’s done.

After that wat done I can now select the patches and have a ton of different sounds 🙂 Even after switching the SY85 off and on again everything still works fine so the new backup battery seems to be doing it’s job.

Still 2 little problems though: every time I power it up it says something like ‘Internal memory configuration changed! Press Exit’ which is a little annoying. There is also a TON of dust behind the LCD. Hmm.

First the memory problem. After a little googling I found the solution:

(1) Go to the wave utility mode (Shift + Utility)
(2) Go to the Wave Initialize page (the Seq Setup button)
(3) Select Volatile Memory (probably selected by default)
(4) Press Enter
(5) Press the Shift button to check the total free volatile memory

Exept this didn’t work :’) I had to change the 3rd part ‘Volatile memory’ to ‘All memory’ for the message to finally go away. I still had all the patches in the User and Performance memory so it’s fine for now.

Then the display. In order to get to it I had to remove: the bottom plate, the mainboard, the other smaller board next to it. The small metal frame that holds the keybed and the big metal frame underneath the mainboard… not a small job.

In the top left picture you can see the dust even when I made a picture in the dark. It was really bad. It’s a lot of work to get to the display but I’m glad I cleaned it. It looks so much better now 🙂

I have a fully working SY85 now and it sounds absolutely great!

Advertisements

One thought on “Yamaha SY85

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s